探検


rep2 part68

■ このスレッドは過去ログ倉庫に格納されています
2021/09/21(火) 18:33:14.88ID:vN1iaRJT0
※■公式p2はこのスレでは扱っていません■※

ブラウザから 2ちゃんねる、まちBBS、JBBS@したらばBBS 等の
掲示板を快適に閲覧するためのPHPスクリプトです。
Mac OS X、UNIX、Linux、Windows などで動くマルチプラットフォーム設計。
ソースは公開されています。

※このスクリプトを動作させるためには、サーバを動かしてPHPを走らせる必要があります。
※荒れる元なのでレンタル鯖やVPSにp2を設置する話題はしない&スルーしてください。
※不具合は怒らず煽らず落ち着いて報告しましょう。

■公式ページ
rep2 expack 全部入り by open774
https://github.com/open774/p2-php
p2 - PHPでつくった2ch Viewer
http://akid.s17.xrea.com/
p2Wiki
http://akid.s17.xrea.com/p2puki/

■前スレ
rep2 part67
http://egg.5ch.net/test/read.cgi/software/1602673030/
2022/04/19(火) 11:04:22.98ID:J3vQknR70
>>680
そのphp8版とproxy2chで書けるね
proxy2chは今日更新入ったやつで問題なし
2022/04/19(火) 13:11:51.03ID:bKD17Zqk0
docker-proxy2chも最新のmasterで試してみた
問題ないかな
2022/04/19(火) 14:27:01.09ID:zEqr/7QZ0
dockerの人見てたら教えて欲しいんですが、
docker-proxy2ch v20220415で時々dockerごと落ちて再起動してるんだけど、ログを見るといつも

Tunneling connection to i.imgur.com:443

のあとに落ちてる
imgurにアクセスしにいくときにproxy2chがエラー吐くならともかく、
dockerごと落ちて再起動となるとproxy2chの問題としていいのか分からないんですが、
何が問題なのか分かりますか?
2022/04/19(火) 14:38:53.54ID:J3vQknR70
Dockerを何で動かしてるのか知らんが、その環境のせいかもしれない。特にMac・・・
つまり再現しない可能性がある。
2022/04/19(火) 18:18:18.20ID:awsScRBY0
>>685
起動スクリプトrc.entryの最後でproxy2chをexecして「ずっと動く」ことを期待しちゃってるので、もしproxy2chがエラーなどで終了したらコンテナもstopします。
ダサいだけで異常動作ではないです。

簡単な対策は、 execをやめつつ無限ループで囲むことです。
参考: https://github.com/pen/docker-rep2/blob/main/rootfs/etc/rc.entry#L22-L25
2022/04/20(水) 14:16:43.86ID:+KwarFCi0
鯖落ち?これが返ってくるようになってるキズナ鯖
rep2 info: 板サーバから最新のスレッド情報を取得できませんでした。
2022/04/20(水) 14:30:04.28ID:+KwarFCi0
あれ?nova鯖も読み込めなかった
ブロックされてる?
2022/04/20(水) 14:38:49.35ID:+KwarFCi0
直った・・・運営がメンテしてただけかな
2022/04/20(水) 14:38:51.97ID:tZmIRRpl0
どのスレ?
2022/04/20(水) 14:48:07.36ID:cbxJBUeb0
一時的になんJ、なんG、週刊少年漫画あたりの板がAPI経由で読めなくなってたね
Webブラウザ直なら読めたし書けた
今は直ったみたいだから気にしなくて良いと思う
2022/04/20(水) 21:15:14.17ID:eiS/gR6X0
書ける?
2022/04/20(水) 21:18:01.59ID:eiS/gR6X0
>>262
新仕様になってからずっと書けなくて悩んでいたんだが
これで解決した
2022/04/21(木) 00:25:08.59ID:j7nF4UEe0
よくってよ
2022/04/21(木) 01:50:35.33ID:PtXyCvna0
>>401です
設定管理の「履歴・キャッシュの削除」からCookieを削除したら書けるようになりました
報告をカキコ
2022/04/21(木) 10:14:02.23ID:4+tsnOWi0
んご
2022/04/21(木) 10:42:52.99ID:IRy0WMIn0
無とはいったい…ンゴゴゴ!
2022/04/21(木) 11:40:01.28ID:T6kIBswK0
そして私もスレ落ちしよう、永遠に!
2022/04/21(木) 13:00:09.69ID:7dsZmM/p0
rep2 expack 全部入り php80 + 2chproxy.pl で、
数日前からスレ一覧は表示されるものの、スレを選択すると

サーバ接続エラー: Curl error: Empty reply from server
rep2 error:
板サーバへの接続に失敗しました。

が出るようになったのって、オレ環?
ちなみにコマンドラインから
curl -sS エラーになったURL
でDATは取得できる
2022/04/21(木) 22:26:13.28ID:PMGtEZxm0
書き込みのテキストエリアに文字書いた後、投稿しないで一旦閉じると、
次に書き込もうとしたとき下書きみたいに残ってると思うんだけど、
rep2 PHP8.0にしてからそれが文字化けするようになった
rep2 PHP8.0ってどこかUTF-8にしてる?それをrep2はShiftJISで読もうとしてるのかな?
2022/04/21(木) 23:30:59.66ID:w+vIHEKE0
open774:masterとmikoim:php8-mergeのcommitsを読んだ上で聞いてるんだよな?
2022/04/22(金) 04:29:09.58ID:R8Yo56u+0
>>701
マ?直しとくわ
2022/04/22(金) 12:28:59.78ID:e2jHTXRU0
もしかして旧APIで読むことすらできなくなった?
2022/04/22(金) 12:39:28.57ID:Xkd6M9Lh0
読めるよ
2022/04/22(金) 13:03:54.74ID:Xkd6M9Lh0
Ubuntu 22.04はphp8.1なんだな・・・
mikoim:php8-mergeはそのままでも動くだろうか?
php8.1で動かしてる人いる?
2022/04/22(金) 13:20:03.11ID:W6Z4i4BS0
>>706
20.04だけど、8.1で動かしてるよ
2022/04/22(金) 13:22:06.82ID:Xkd6M9Lh0
>>707
おおそうか!サンクス
ondrejのPPAから8.1入れようと思ってたけどUbuntu標準のがいい・・・
2022/04/22(金) 14:50:02.12ID:R8Yo56u+0
新しい謎の文字列に変えたら読めるようになった
2022/04/22(金) 18:22:38.87ID:Xkd6M9Lh0
家やスマホだと書けるのに、ネットカフェからだと書けない。
正確には一回だけ書けたけどそれ以降はダメだな。
2022/04/22(金) 18:32:10.25ID:qqnPY6Yu0
切り分けできてない問題はすべておま環やぞ
2022/04/22(金) 19:59:25.90ID:RTOU+86M0
長年使ってきたAppKeyとHMkeyが使えなくなった
使えるやつをやっと見つけた
2022/04/22(金) 20:51:17.40ID:CoNyV4G+0
PHP8対応って前スレか前々スレあたりにあったっけ
open774そのままじゃダメだよね
2022/04/22(金) 21:06:35.48ID:08UaaUn10
知恵遅れで学習障害児の俺でも分かるように教えてくれよ!
2022/04/22(金) 22:03:29.18ID:FYhjDQ/i0
手抜きしようとしたら厳しい御言葉ありがとうございます
2スレほど遡ってみてpastebinにアップされたらしいファイルを落としてpatch当てようとしたらなかったので
大人しくopen774からmikoimにリポジトリ切り替え
 git remote set-url origin https://github.com/mikoim/p2-php

リポジトリ追加してPHP8.1関連パッケージインストール
 # sudo add-apt-repository ppa:ondrej/php
 # sudo apt install php8.1 php8.1-intl php8.1-mbstring php8.1-mysql php8.1-gd php8.1-fpm

でphp -v叩いてPHP8.1に切り替わってることを確認して鯖再起動
rep2の読み込み、書き込みは特に異常なし
よくimagecacheでimgurのイメージ引っ張るの失敗するのは変わらなかったので
PHP8.1での動作に切り替えはうまくいったんじゃないかなと思ってたり
2022/04/22(金) 22:14:30.72ID:mf9S9snm0
今宵はコードと戦わずにすみそうだなw
2022/04/22(金) 22:20:27.53ID:CoNyV4G+0
あ、gitのリポジトリ切り替えた後はremote -vで切り替わったの確認してからpullしてます
大事なこと忘れてた
2022/04/22(金) 23:44:40.39ID:5sV3zLK+0
brewにphp7.4は面倒見ないよ!って怒られた
8.1にすべきなのか
719700
垢版 |
2022/04/23(土) 12:33:46.40ID:YH6C+fDl0
>>700
オレ環でした。2chproxy.plをproxy2chに変更したらエラー出なくなりました。
2022/04/23(土) 14:30:55.80ID:Qosb6p/c0
2chproxy.plはDAT落ちしたスレを読むために重宝する
2022/04/23(土) 19:55:31.65ID:Tv4y0qr+0
めんどいな
2022/04/24(日) 14:18:06.02ID:wQpmFs0J0
とうとうroになってしまった
2022/04/24(日) 14:43:55.07ID:Az1//B7C0
orz
2022/04/24(日) 15:33:15.89ID:YrJSmYSn0
書き込みテスト
2022/04/24(日) 16:00:58.18ID:w6K+fcII0
>>722
その虚しさを心にしまって何度でも立ち上がるんだ、どこかにある何かがある
2022/04/24(日) 19:45:31.61ID:XFgPkNzu0
100%書けないだろうけど、テスト
2022/04/24(日) 20:52:16.31ID:YSBJ2FcS0
書けてるやないかーい
2022/04/24(日) 22:38:04.88ID:5EX70JxF0
オレは何もしてないので絶対書けない。
2022/04/24(日) 23:13:04.46ID:YrJSmYSn0
書き込めないレスは変換スクリプトへ誘導するフェイクだったの?
2022/04/25(月) 13:34:12.69ID:NzzRaGem0
php8.1に上げたけど確かに問題ないな
2022/04/26(火) 11:07:56.59ID:qa/aRuVj0
テスト
2022/04/26(火) 11:08:13.85ID:qa/aRuVj0
dockerおじさんありがとう!!
2022/04/26(火) 14:11:04.96ID:CPQacuKF0
未だに不正なproxyから抜け出せない
2022/04/26(火) 14:22:17.25ID:qa/aRuVj0
ニュー速+書けなくなった
2022/04/26(火) 14:45:11.05ID:n9XJ54kx0
>>733
送信してるデータに変なのくっ付いてる
送信してるデータが足りない場合は、データが壊れていますとか、
新仕様に対応したブラウザにしろとかになる
KeyとUAが合ってないなら一致してませんエラーとか
2022/04/26(火) 14:48:46.05ID:n9XJ54kx0
>>734
書けないじゃなくてエラー内容言えよ
普通にニュー速にも今書けたわ
2022/04/26(火) 15:20:01.49ID:tTucqaW90
+の方が規制厳しいよな。
API使わずに頑張ってるけど。
2022/04/26(火) 15:29:20.39ID:6GbEjXoT0
>>733
Sec-Fetch-Dest:
Sec-Fetch-User:
Sec-Fetch-Mode:
Sec-Fetch-Site:
Upgrade-Insecure-Requests:

この辺のヘッダーが送られてたら送られないように細工する
2022/04/26(火) 15:32:45.40ID:n9XJ54kx0
>>736はニュー速じゃなくニュー速+だわ、普通に書けた
ニュー速とか普段いかないから何が無印で何が+なのか知らんけど
2022/04/26(火) 15:39:04.21ID:qa/aRuVj0
ERROR: 余所でやってください。[newsplus]

これでニュー速+書けねえ
2022/04/26(火) 15:53:52.95ID:tTucqaW90
>>740
UA規制が厳しくてWhndowsの主要ブラウザでも蹴られる。意味不明の厳しさよ。
2022/04/26(火) 16:04:13.17ID:n9XJ54kx0
>>740
余所エラーは使ってるUAが問題だから変えよう
2022/04/26(火) 16:32:47.77ID:cgfUjx6M0
UAに問題なければ旧APIでも書けるよ
2022/04/26(火) 21:10:05.88ID:qa/aRuVj0
UA探しに疲れ果てた
2022/04/26(火) 21:23:55.48ID:cgfUjx6M0
>>744
このスレにヒントがある
2022/04/26(火) 22:18:01.69ID:tTucqaW90
>>743
API使わなくてもUA弄るだけでも読み書きできてるよ。
2022/04/26(火) 22:29:36.34ID:2lffzxbN0
同じくUAだけ
2022/04/26(火) 22:39:59.96ID:F/38mfdx0
何系UAなの
2022/04/26(火) 22:44:02.38ID:tTucqaW90
>>748
専ブラではないよ。専ブラのUAチェックが緩かったのは4月頭までだった…。
2022/04/26(火) 23:59:29.97ID:zQJAJNW70
Ubuntu22.04LTSにあげたらrep2が
HTTP ERROR 500
で起動しなくなった
phpinfoで情報参照したりWordpressは動いたりしてるから
PHPの環境自体に問題はない気がするんだがなぁ
2022/04/27(水) 00:04:27.54ID:F3U93Bk70
ログを見ろとしか言いようがない
2022/04/27(水) 07:24:13.04ID:rHy9F4n50
どのブランチを使ってhttpdやphpが何かなどの情報が欠けている
そもそもログ見ろだが
2022/04/27(水) 10:47:31.59ID:ZW7xZEFD0
鯖不調で環境再構築したのですが新環境で2chproxy.plのDAT取得プラグインが機能しなくなってしまった
DAT取得ボタン押すと↓

サーバ接続エラー: Curl error: Proxy CONNECT aborted due to timeout
rep2 error: 板サーバへの接続に失敗しました。

2chproxy.pl事態は書き込み出来ないがDAT取得事態は普通に機能しています
ですがphpファイル経由だと取得出来ない
前環境ではDAT取得プラグインは機能していた
因みにphpの記述は

<?php
exec("curl -s -L {$_GET['u']} | /usr/local/bin/2chproxy.pl -p", $output);
foreach ($output as $line) {
echo mb_convert_encoding($line, "CP932", "UTF-8")."\n";
}

原因はなにが考えられますか?
2022/04/27(水) 10:54:53.23ID:CzN1ALtK0
>>753
サーバが自分自身の名前解決ができてないに一票
2022/04/27(水) 11:38:50.57ID:F3U93Bk70
>>753
DAT取得プラグインの設定はどうなってるんだ?
2022/04/27(水) 12:10:55.52ID:ZW7xZEFD0
DAT取得プラグイン一度削除して再登録したけど
ボタンすら出なくなった
rep2事態そのまま引っ越したんだけどそれが原因かなと思って
新規で入れたけどやっぱりDAT取得プラグインの登録出来ないです

2chprixy
(.+)
https://自鯖ドメイン/2chproxy.php?u=$1

php7.4だけどなにか足りないのかな?
この問題以外は正常に動いてるんだけど2chproxyで書き込みも出来てるし
DATは諦めるか・・・
2022/04/27(水) 12:15:49.12ID:F3U93Bk70
>>756
設定はあってるようだけど>>752が指摘してる点は確認しないの?

https://自鯖ドメイン/2chproxy.php?u=DATのURL
をcurlで叩くとどうなる?
2022/04/27(水) 13:13:48.58ID:F3U93Bk70
API鯖落ちたっぽいな
2022/04/28(木) 09:02:27.66ID:yetBHzOS0
proxy2chで倉庫のdat取れる?
2022/04/28(木) 10:55:04.35ID:wP8dkUoP0
いろいろいじったけどまだ書けない
2022/04/29(金) 11:01:50.22ID:KdvX+MqK0
またニュー速+が他所でやれになる
2022/04/29(金) 11:04:56.34ID:KdvX+MqK0
と思ったら書けた
2022/04/29(金) 11:24:17.59ID:n499K0I40
>>750です

Ubuntu20.04LTSに上げたらrep2が起動しなくなった件です
鯖周りはnginx + PHP8.1 + PHP8.1-FPMです

・PHP8.1-FPMのステータス
$ systemctl status php8.1-fpm
● php8.1-fpm.service - The PHP 8.1 FastCGI Process Manager
Loaded: loaded (/lib/systemd/system/php8.1-fpm.service; enabled; vendor preset: enabled)
Active: active (running) since Fri 2022-04-29 11:08:00 JST; 4min 57s ago
Docs: man:php-fpm8.1(8)
Process: 2077 ExecStartPost=/usr/lib/php/php-fpm-socket-helper install /run/php/php-fpm.sock /etc/php/8.1/fpm/pool.d/www.conf 81 (code=exited, status=0/SUCCESS)
Main PID: 2074 (php-fpm8.1)
Status: "Processes active: 0, idle: 2, Requests: 6, slow: 0, Traffic: 0req/sec"
Tasks: 3 (limit: 14158)
Memory: 52.3M
CPU: 20.994s
CGroup: /system.slice/php8.1-fpm.service
tq2074 "php-fpm: master process (/etc/php/8.1/fpm/php-fpm.conf)" "" "" "" "" "" "" "" "" "" "" "" "" "" "" "" "" "" "" "" "" "" ""
       tq2075 "php-fpm: pool www" "" "" "" "" "" "" "" "" "" "" "" "" "" "" "" "" "" "" "" "" "" "" "" "" "" "" "" "" "" "" "" "" "" "" "" "" "" "" "" "" "" "" "">
2022/04/29(金) 11:26:36.69ID:n499K0I40
続きまして
/etc/nginx/sites-available\default

location ~ \.php$ {
try_files $uri =404;
# fastcgi_pass unix:/var/run/php/php7.4-fpm.sock;
fastcgi_pass unix:/run/php/php8.1-fpm.sock;
fastcgi_index index.php;
fastcgi_param SCRIPT_FILENAME $document_root$fastcgi_script_name;
include fastcgi_params;


hoge@hogehoge:/run/php$ ls -la
合計 4
drwxr-xr-x 2 www-data www-data 100 4月 29 11:08 .
drwxr-xr-x 39 root root 1200 4月 29 11:10 ..
lrwxrwxrwx 1 root root 30 4月 29 11:03 php-fpm.sock -> /etc/alternatives/php-fpm.sock
-rw-r--r-- 1 root root 4 4月 29 11:08 php8.1-fpm.pid
srw-rw---- 1 www-data www-data 0 4月 29 11:08 php8.1-fpm.sock
hoge@hogehoge:

PHP-FPMのsocket間通信がうまくいってない気がしてます
同じ鯖で動かしてるWordpressは動いてます

どなたかお知恵を拝借願えないでしょうか
2022/04/29(金) 11:34:24.70ID:KdvX+MqK0
>>763
22.04じゃなくて20.04なの?
あとnginxのログはどうなってるんだよ?確認するポイントが全然違う。
2022/04/29(金) 13:27:24.89ID:n499K0I40
>>765
ありがとうございます
Ubuntu22.04LTSでした ややこしくしてしまい申し訳ございません
nginxのaccess.logとerror.logはアクセスした際に次のように記録されていました
・/var/log/nginx/access.log
192.168.0.7 - - [29/Apr/2022:13:07:13 +0900] "GET /hogehoge/rep2/index.php HTTP/1.1" 500 5 "-" "Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/101.0.4951.41 Safari/537.36"
192.168.0.7 - - [29/Apr/2022:13:18:08 +0900] "GET /hogehoge/rep2/index.php HTTP/1.1" 500 5 "-" "Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/101.0.4951.41 Safari/537.36"

・/var/log/nginx/error.log
2022/04/29 13:18:08 [error] 2193#2193: *95 FastCGI sent in stderr: "PHP message: PHP Fatal error: Uncaught Error: Non-static method Net_UserAgent_Mobile::singleton() cannot be called statically in /home/hoge/share/htdocs/hogehog/erep2/lib/bootstrap.php:159
Stack trace:
#0 /home/hoge/share/htdocs/hogehoge/conf/conf.inc.php(292): include()
#1 /home/hoge/share/htdocs/hogehoge/conf/conf.inc.php(53): p2_init()
#2 /home/hoge/share/htdocs/hogehoge/init.php(4): require('...')
#3 /home/hoge/share/htdocs/hogehoge/rep2/index.php(13): require_once('...')
#4 {main}
thrown in /home/hoge/share/htdocs/hogehoge/lib/bootstrap.php on line 159" while reading response header from upstream, client: 192.168.0.7, server: nantoka.nantoka.com, request: "GET /home/hoge/share/htdocs/hogehoge/index.php HTTP/1.1", upstream: "fastcgi://unix:/run/php/php8.1-fpm.sock:", host: "nantoka.nantoka.com"
2022/04/29(金) 13:37:05.21ID:KdvX+MqK0
>>766
PEARのモジュールが古いんじゃねえの?

php8.1 scripts/p2cmd.php update
を実行するとどうなる?
2022/04/29(金) 13:38:48.10ID:KdvX+MqK0
php8.1 scripts/p2cmd.php check
実行するとどうなる?全部OK出てる?
2022/04/29(金) 13:51:44.05ID:1dyk/Bv20
22.04LTS
2022/04/29(金) 13:55:01.87ID:1dyk/Bv20
すまん、ひとまず手元の仮想環境に22.04LTS+php8.1+Apache2+php8.1版rep2
な環境組んでみたら、なんの問題もなく動いたし書き込みもできたわ
2022/04/29(金) 16:19:38.90ID:5bsGfhmQ0
>>770
8.1版なんて出来たの?
8.0版とどこが違うの?
2022/04/29(金) 16:25:33.36ID:n499K0I40
>>767,768
どうもありがとう
PEARのモジュール古かったみたいでアップデートしたけど変わらずだった
p2cmd.php checkは全部OKになってる
https://i.imgur.com/hTCNXzW.jpg

phpinfo確認するとServer APIはFastCGIになってる
https://i.imgur.com/21INbSO.jpg

fpmのログ出力させてみたらこんな感じ
[29-Apr-2022 15:54:08] NOTICE: fpm is running, pid 15793
[29-Apr-2022 15:54:08] NOTICE: ready to handle connections
[29-Apr-2022 15:54:08] NOTICE: systemd monitor interval set to 10000ms
[29-Apr-2022 15:54:12] NOTICE: Terminating ...
[29-Apr-2022 15:54:12] NOTICE: exiting, bye-bye!
[29-Apr-2022 15:54:13] NOTICE: fpm is running, pid 15826
[29-Apr-2022 15:54:13] NOTICE: ready to handle connections
[29-Apr-2022 15:54:13] NOTICE: systemd monitor interval set to 10000ms
[29-Apr-2022 15:54:37] NOTICE: Terminating ...
[29-Apr-2022 15:54:38] NOTICE: exiting, bye-bye!
[29-Apr-2022 15:55:47] NOTICE: fpm is running, pid 965
[29-Apr-2022 15:55:47] NOTICE: ready to handle connections
[29-Apr-2022 15:55:47] NOTICE: systemd monitor interval set to 10000ms
2022/04/29(金) 18:30:24.22ID:1dyk/Bv20
>>771
すまんな8.x版だわな
2022/04/29(金) 18:52:12.76ID:1dyk/Bv20
>>772
試しにnginxも入れてapacheと同じサーバーrootでport8000で動かしてみたが動作に問題はなかった

nginx 1.18.0
php 8.1.2
2022/04/29(金) 18:54:20.78ID:1dyk/Bv20
nginxの方はphp-fpmの構成ね
2022/04/29(金) 20:24:06.63ID:n499K0I40
>>774
色々試行して下さってありがとうございます

$ php -v
PHP 8.1.2 (cli) (built: Apr 7 2022 17:46:26) (NTS)
Copyright (c) The PHP Group
Zend Engine v4.1.2, Copyright (c) Zend Technologies
with Zend OPcache v8.1.2, Copyright (c), by Zend Technologies
with Xdebug v3.1.2, Copyright (c) 2002-2021, by Derick Rethans

$ nginx -v
nginx version: nginx/1.18.0 (Ubuntu)

$ sudo nginx -t
nginx: the configuration file /etc/nginx/nginx.conf syntax is ok
nginx: configuration file /etc/nginx/nginx.conf test is successful

でnginxの設定ファイル周りにエラーやワーニングは出てません

/run/php配下はこんな感じです
$ ls -la /run/php/
合計 4
drwxr-xr-x 2 www-data www-data 100 4月 29 15:55 .
drwxr-xr-x 39 root root 1200 4月 29 20:16 ..
lrwxrwxrwx 1 root root 30 4月 29 15:55 php-fpm.sock -> /etc/alternatives/php-fpm.sock
-rw-r--r-- 1 root root 3 4月 29 15:55 php8.1-fpm.pid
srw-rw---- 1 www-data www-data 0 4月 29 15:55 php8.1-fpm.sock
2022/04/29(金) 20:53:09.06ID:KdvX+MqK0
>>764
俺のとこは↓で動いてるな

location ~ \.php$ {
include snippets/fastcgi-php.conf;
fastcgi_pass unix:/run/php/php8.1-fpm.sock;
}
2022/04/29(金) 22:17:41.73ID:1dyk/Bv20
>>774のあとに本番環境を22.04LTSにdo_release_upgrade -dして壊したわ
もう面倒くさくなってクリーンインストールして(データ類は別パーティションにあるから問題ない)
やっとrep2が繋がった
2022/04/29(金) 23:24:19.87ID:n499K0I40
phpinfo表示させると
 Server API:FPM/FastCGI
 cgi-fcgiのphp-fpm項:active
になってるしでなぜrep2がダメなのかほんと分からん……困ったぞい
Ubuntuの環境自体をイメージバックアップ取った後
まっさらから22.04 LTSで作り直そうかしらね
780名無しさん@お腹いっぱい。
垢版 |
2022/04/30(土) 14:49:36.77ID:szkwNS/V0
ERROR: もう新しいのにしましょ。
これで書けなくなった、もう新しいのにしましょ。は初だ
2022/04/30(土) 15:58:56.89ID:gy6q7LOp0
>>780
UAのOSバージョンが古いとこのメッセージになるにょ
2022/04/30(土) 16:04:46.88ID:+8Q/9eg10
>>781
古いUAにしてたので新しいのにしたらかけました
ありが㌧
2022/05/03(火) 20:57:04.89ID:33GatiHl0
dockerとsample.lua使って読み書き出来るようになったけどニュー速+だけ何が何でも余所エラーになるで
どうしたらええんや
■ このスレッドは過去ログ倉庫に格納されています

ニューススポーツなんでも実況